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Criar o primeiro Projecto

Imediatamente após o primeiro arranque, o software abre o painel Startup e propõe-se carregar o Demo
“Villy the Devil” ou iniciar uma nova Cena.

Como criar uma nova Cena implica que já exista uma Directoria dedicada ao nosso novo Projecto, e o
Browser deste painel não deixa criar novas Directorias mas tão somente escolher entre as já existentes,
fazemos Cancel e vamos até ao Windows para criar uma nova área de trabalho.

No caso que vamos desenvolver como exemplo, optámos por criar a seguinte Directoria para o Projecto:
D:\Futebol\
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Criar a primeira Cena de um Projecto

Depois de estabelecida a Directoria de trabalho para o Projecto, activamos o menú File >
New Scene (Ctrl+N) para abrir o painel New scene, semelhante ao painel Startup.

Em qualquer dos casos damos o nome “Plano1” à nossa primeira Cena, e a etapa
seguinte é definir algumas das suas características, utilizando o painel que se abre
imediatamente a seguir.
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Definição das características da Cena

Algumas características da Cena, tais como o tamanho com que as imagens serão
calculadas, a quantas imagens por segundo, qual foi o Enquadramento utilizado pelos
animadores, e outras, são definidas no painel Scene properties:

As opções críticas são definidas em Scene properties: General, e implicam algum
conhecimento prévio sobre o trabalho em curso. Uma vez introduzidas,  algumas destas
características não podem ser alteradas mais tarde. Decisões correctas têm que ser
tomadas agora.

As opções propostas pelo software são:

o sistema norte-americano NTSC (720x540 pixels, 30 imagens/segundo);

o sistema europeu PAL (768x576, 25 imagens/segundo;

o sistema VGA (640x480 pixels, 25 imagens/segundo);

um sistema livre OTHER.

Através deste último definimos a largura Width e a altura Heigh, até um máximo de 8192x8192 pixels, e o
número de imagens por segundo Frames/second que o filme vai ter (25 para vídeo PAL, 24 para cinema).

O Enquadramento utilizado pelos animadores é declarado em Fields.
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No caso que estamos a desenvolver como exemplo, o filme é parte de um spot publicitário para televisão
(25 imagens por segundo) e o dispositivo de saída final é uma placa DPS Perception (resolução D1/PAL =
720x576 pixels) ligada a um videogravador Betacam SP.

O animador utilizou o Campo 12 da Folha de Enquadramentos no seu trabalho.

Informações complementares são introduzidas em Scene properties: Staff.
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Se depois de validarmos estas características com    consultarmos o menú File > Open Scene
(Ctrl+O) encontramos o seguinte:

O painel Open scene mostra as Cenas criadas dentro deste Projecto.

Por enquanto temos apenas o “Plano1”, ainda vazio (Frames = 0).

Através do menú Edit > Scene Properties… (Alt+Enter) abrimos este painel:

Como se pode constatar, as opções críticas anteriormente introduzidas já não podem ser alteradas,
apenas consultadas.
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Entretanto, como consequência destas acções o software criou uma nova pasta dentro da Directoria do
Projecto:

Dentro desta nova pasta, “Plano1”, o software criou dois ficheiros para uso próprio – não
mexer!
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Adicionar e Remover Cenas, mudar de Projecto

Para adicionar Cenas File > New Scene (Ctrl+N) faz abrir um painel que mostra as Cenas já criadas
dentro deste Projecto e permite adicionar novas Cenas.

O nome da Cena a adicionar é colocado em Scene Name. Imediatamente a seguir abre-se o painel
Scene properties:



CTP Pro Guia de Treinamento

© Crater Software 1999-2012
    www.CraterSoftware.com

12

E assim sucessivamente, até termos criado três Cenas: “Plano1 - Futebolista chutando”, “Plano2 -
Golo!” e “Plano3 - Yes!”.

Aqui introduzimos uma Cena extra, “Lixo”, para ser posteriormente apagada.

Depois de completar todas estas operações, a situação no disco do computador passou a ser:

Para remover a Cena “Lixo”, basta ir ao menú File > Remove Scene… e abrir o painel Remove
scene. Se nesse momento esta fôr a Cena activa, somos avisados de que temos que a fechar
primeiro.

Isso consegue-se com File > Close. Podemos então remover qualquer Cena através de File >
Remove Scene… activando-a e clicando  .
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Após esta operação a situação no disco do computador passou a ser…

… e a escolha de qualquer Cena faz-se através de menú File > Open Scene… (Ctrl+O)
simplesmente activando-a e clicando  .

A mudança de Projecto pode ser feita através do Browser deste painel, se a Directoria de trabalho
desse Projecto já existir. Caso contrário será necessário criar essa área de trabalho no Windows,
previamente.
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Captura por Scanner, preparativos

No caso que estamos a desenvolver como exemplo, utilizámos um scanner da
Hewlett-Packard Co., um ScanJet, com drivers DeskScan para Windows.

Utilizámos ainda um alimentador automático ScanJet ADF com um transportador de
papel modificado – pintado de negro, para evidenciar as furações do papel.
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O software faz a captura tanto a partir do menú Insert > Image from Scanner,
como através do botão Import Image from Scanner.

Em qualquer dos casos o software entra em modo de captura e abre-se um painel
de comando do scanner.

Neste caso o software já identificou o scanner:

Source = DeskScan (de facto o driver TWAIN instalado);
Page size = 8.50 x 14.00 inches (o tamanho do vidro do scanner).

Para adaptar o painel ao nosso trabalho, escolhemos capturar em tons de cinzento:
Scan Type = Gray Levels.
Mantemos o Campo 12 em Resolution = 12 fields (60 dpi)
Activamos as opções Auto feeder e Multiple pages para usar o alimentador
automático do scanner.
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Fazendo um Preview o nosso primeiro desenho aparece no ecrã, e o painel de
comando do scanner muda de Source para Import Setup.

Existe um conjunto de iconos que controlam aquilo que visualizamos:

Mostra o desenho com o seu tamanho real (escala 1:1).
Mostra a folha toda, mudando a escala do desenho.
Mostra as zonas transparentes em axadrezado.
Mostra as zonas transparentes a vermelho.
Mostra as linha de demarcação da sombra.
Mostra o Rectângulo Vermelho que delimita a zona de interesse.
Mostra a Folha de Enquadramentos.
Mostra a Régua de Pinos (Peg Bar).
Coloca a Régua de Pinos na horizontal.
Coloca a Régua de Pinos na vertical.
Tranca ou destranca a Régua de Pinos e a Folha de Enquadramentos.
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No painel Import Setup activamos a opção Line Image, uma vez que vamos
capturar traço, e deixamos o filtro em Only prefilter.

Comecemos pelo Rectângulo Vermelho .
Analizando a sequência de desenhos fornecida pelo animador, procuramos as
posições extremas do desenho ao longo da animação, e fazemos um Preview para
cada um desses desenhos. Isto permite-nos ir abrindo ou fechando o Rectângulo
Vermelho de modo a optimizar o seu tamanho.

O tamanho final do Rectângulo pode ser visto em unidades de Enquadramento, em
pixels ou em polegadas em Image Size.
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Com os actuais parâmetros de trabalho, o tamanho máximo do Rectângulo
Vermelho é de 660x510 pixels (e não os nossos 720x576 D1/PAL ?!), ou
11.00x8.50 polegadas (ok: o vidro do scanner tem 14.00x8.50) e Campo 11 (e não o
nosso Campo 12 ?!).

Agora apuramos a qualidade do traço. Para isso experimentamos os filtros no painel
Import Setup.

Os pré-definidos são:

Only prefilter Softness: = 5

Camera Sensitivity: = 60
Highlights: = 50
Shadows: = 0
Softness = 5

Scanner Sensitivity: = 60
Highlights: = 90
Shadows: = 99
Softness = 5

Opaque Lines Sensitivity: = 60
Highlights: = 90
Shadows: = 99
Softness = 5

No caso concreto do nosso exemplo conseguimos excelentes resultados com o filtro
Opaque Lines.
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Se utilizarmos  para visualizar as zonas transparentes a vermelho, obtemos:

Note-se que uma certa quantidade de “papel branco” à volta do traço é de facto
benéfica – ajuda a preservar o anti-aliasing do traço negro.
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O passo seguinte é activar a Régua de Pinos .

Este último icono teve como efeito activar o Cadeado  e fazer surgir no ecrã uma
representação virtual da Régua de Pinos (azul). Como o Cadeado está activo, a
Régua de Pinos está trancada (Locked).
Destrancamos o Cadeado   e a Régua de Pinos fica activa (traço cheio em vez
de tracejado).

A Régua de Pinos é arrastada até coincidir com a Furação. Pequenos acertos
podem ser feitos usando o teclado (teclas de cursor).
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Vamos agora reposicionar a Folha de Enquadramentos .
O Cadeado tem que continuar destrancado.
Quando revelada pela primeira vez, a Folha aparece centrada com a Régua.

A Folha acompanha os movimentos da Régua, mas pode, por sua vez, ser movida
independentemente. Para activar a Folha (verde) basta picar sobre ela numa zona fora
da influência da Régua (azul) ou do Rectângulo (vermelho).

Depois de feitos todos os acertos, voltar a trancar o Cadeado para imobilizar a Régua
de Pinos e a Folha de Enquadramentos.
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Nesta fase do trabalho é adequado fazer um Close, aceitando os parâmetros
introduzidos até agora, e fazer um File > Save (Ctrl+S).

Isto actualiza o ficheiro “Plano1.PLN” que contém informação sobre a nossa Cena
“Plano1” do nosso Projecto “Futebolista”.

Feito isto, podemos mesmo sair do CTP e voltar mais tarde, e os parâmetros do
scanner continuarão a ser os mesmos. Nesse caso o aspecto do painel seria o
seguinte, ao retomar o trabalho:

Como se pode ver, as posições anteriores da Régua de Pinos, da Folha de
Enquadramentos e do Rectângulo Vermelho, mantiveram-se.



 CTP Pro Guia de Treinamento

© Crater Software 1999-2012
    www.CraterSoftware.com

26

A primeira captura

Recordando, o caso que estamos a desenvolver como exemplo é parte de um spot
publicitário para televisão e o dispositivo de saída final é uma placa DPS Perception
D1/PAL.
O animador usou o Campo 12 da Folha de Enquadramentos.

No disco do computador foi criada uma Directoria para o Projecto em:
D:\Futebol

Foram criadas três Cenas:
Plano1 – Futebolista chutando
Plano2 – Golo!
Plano3 – Yes!

Ao Plano1 foram dadas as seguintes características:
Resolução final D1/PAL = 720x576 pixels
Frequência = 25 imagens por segundo

À sequência que vamos capturar foram dadas as seguintes características:
Estilo de captura = tons de cinzento
Resolução de captura = Campo 12 (60 dpi)

O rectângulo de corte (vermelho) foi dimensionado de acordo com a animação, a
Régua de Pinos foi posicionada sobre as furações, a Folha de Enquadramentos foi
reposicionada de maneira adequada segundo instruções do animador.

A sequência que vamos capturar tem 41 desenhos.
Vamos atribuir um nome a esta sequência, para efeitos de captura, e dizer onde
queremos colocar os desenhos digitalizados.

O software impõe uma estrutura para o nome: tem que ser composto por quatro
algarismos e uma letra (####§). Quanto ao armazenamento dos desenhos, que é
sempre feito num painel especial (Storage Sheet), podemos escolher entre várias
colunas: OVL, A, B, C, BGR (Overlay, A, B, C, Background).
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No presente caso vamos optar pela coluna “A”.
O nome muda automaticamente para 0001A, mas pode ser modificado se houver
razões para isso (com a restrição de ter o formato ####§).
O software é informado de que o scanner tem um alimentador automático:
Auto Feeder
Multiple pages

Coloca-se a pilha de desenhos no alimentador do scanner e faz-se um Preview para
rectificar a posição da Régua de Pinos. O Enquadramento acompanha os acertos da
Régua. Por norma a posição correcta é definida pelo primeiro desenho.

Depois de feitas todas estas verificações, basta clicar em Import.

À medida que os desenhos vão sendo digitalizados, podemos vê-los tanto no ecrã
como na coluna “A” da zona de armazenamento.

Os desenhos aparecem bem limpos, com toda a área fora do Rectângulo Vermelho
virada a branco. Mesmo as Furações já não aparecem.
Quando se esgotam os desenhos no alimentador o processo pára.

Nesta fase do trabalho podemos fazer um Close, aceitando as modificações entretanto
introduzidas, e fazer um File > Save (Ctrl+S).
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Os desenhos digitalizados ficaram armazenados no disco do computador, dentro da
pasta Plano1 referente à nossa Cena “Plano1” do Projecto “Futebolista”.

Durante a captura vão sendo gerados ficheiros contendo os desenhos (como por exemplo,
S0027A.0.CTP) e ficheiros temporários (TMP.25.CTP). Ao fechar o programa aparecerá a seguinte
pergunta:

Isto diz respeito aos ficheiros temporários. Respondendo Yes o resultado no disco do
computador é ficarem apenas os ficheiros úteis:
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O aspecto da zona de trabalho passou a ser semelhante a:

À direita temos o Armazém (Storage Sheet) com os nossos desenhos digitalizados, à
esquerda temos a Carta de Rodagem (Exposure Sheet) onde iremos construir o nosso
filme.
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 Adicionar capturas

Como quem chuta, chuta alguma coisa, vamos adicionar mais uma sequência à Cena “Plano1” do
Projecto “Futebolista” – vamos capturar uma animação de uma bola de futebol.

Como os parâmetros de captura desta nova sequência são os mesmos, uma vez que o trabalho já vinha
convenientemente preparado pelos animadores, não há quaisquer alterações a fazer às posições da
Régua de Pinos ou da Folha de Enquadramentos.

Há que alterar apenas o Rectângulo Vermelho, para definir uma nova zona de interesse e de limpeza do
papel.

 Entrando novamente em modo de captura por scanner …

… e fazendo Preview aos desenhos adequados, redefinem-se as dimensões do Rectângulo de modo a
abarcar toda a área varrida pela animação.
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Feito isto, constatamos que a posição das Furações se afasta ligeiramente da posição anteriormente
definida para a Régua de Pinos.

Em relação à animação da bola de futebol, o animador forneceu uma anotação dizendo que “não existem
desenhos de 1 a 9”. No caso do futebolista os desenhos iam de 1 a 41, mas no caso da bola vão apenas
de 10 a 41.

Tal como anteriormente teremos que atribuir um nome a esta sequência para efeitos de captura. Vamos
armazená-la na coluna “B” (Image layer: B), e o nome passará a ser 0010B.
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Tal como anteriormente, os desenhos digitalizados foram armazenados no disco do
computador, dentro da pasta Plano1 referente à nossa Cena “Plano1” do Projecto
“Futebolista”.

Durante a captura foram gerados ficheiros contendo os desenhos (como por exemplo, S0010B.0.CTP) e
ficheiros temporários (TMP.35.CTP). Ao fechar o programa aparecerá a seguinte pergunta:

Isto diz respeito aos ficheiros temporários. Respondendo Yes, o resultado é ficarem no
disco do computador apenas os ficheiros úteis. A opção Do not show this dialog
again pode ser activada, evitando assim que o painel volte a surgir.
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Transferir desenhos entre regiões

Uma vez que já temos uma sequência do futebolista e outra da bola, vamos então avançar para a Carta
de Rodagem. O aspecto da nossa zona de trabalho passou a ser semelhante a:

Existem duas regiões bem distintas e independentes:

à direita, no Armazém (Storage Sheet) temos os desenhos capturados;

à esquerda, ainda vazia, temos a Carta de Rodagem (Exposure Sheet).

Na Carta de Rodagem as colunas mais à esquerda ficam por cima das outras mais à direita. Pôr “por
cima” é “pôr mais à esquerda”.

Teremos, por exemplo, que transferir a bola (coluna “B” do Armazém) para a coluna “A” da Carta de
Rodagem, e o futebolista (coluna “A” do Armazém) para a coluna “B”, de modo a que a bola fique por
cima do futebolista.
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Existem diversos modos para iniciar a transferência dos desenhos entre as duas regiões:

1 - Picar e soltar sobre um desenho para o seleccionar, observar que ao cursor se adiciona um pequeno
rectângulo quando se move sobre o desenho seleccionado. Picar e arrastar para o destino.

2 - Picar e soltar sobre um desenho para o seleccionar, premir a tecla de SHIFT e picar noutro desenho
mais abaixo. Cria-se assim uma selecção de vários desenhos, um bloco. Picar e arrastar para o destino.

  

3 - Apontar para um desenho não-seleccionado, picar e arrastar até outro desenho mais abaixo. Picar e
arrastar a selecção para o destino.
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4 - Apontar para o topo de uma coluna e picar para seleccionar toda a coluna. Picar sobre a selecção e
arrastar para o destino.
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Existem diversos modos para soltar a selecção no destino:

1/2/3 - Quando se transfere seja um desenho isolado seja um conjunto de desenhos (um bloco), a
selecção move-se livremente sobre a folha de destino.

4 - Quando se transfere toda uma coluna, o destino é também uma coluna.

De um modo geral, a acção de picar, arrastar e soltar, pode ser substituída por acções de teclado: Ctrl-C
para copiar, picar sobre a célula de destino para a seleccionar, Ctrl-V para finalizar a cópia.
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Exemplificando, vamos então transferir o futebolista para a coluna “B” da Carta de Rodagem,
transferindo “toda a coluna”.

Origem: coluna “A” do Armazém.

Destino: coluna “B” da Carta de Rodagem.
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Continuando, vamos transferir a bola para a coluna “A” da Carta de Rodagem, de modo a ficar por cima
do futebolista. Vamos transferir como “bloco”.

Uma vez que um “bloco” se move livremente sobre a Carta de Rodagem, podemos aproveitar a
oportunidade e acertar os desenhos da bola com os desenhos do futebolista – desenho 10 da bola
coincidente com o desenho 10 do futebolista, e assim por diante.
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Ver os desenhos transferidos

Não existe qualquer processo para ver os desenhos enquanto estão no Armazém, apenas podem ser
vistos depois de transferidos para a Carta de Rodagem, picando sobre eles.

O estado em que se encontram os botões  e  influencia o modo como a imagem é exibida na
área de visualização. Para ver a composição final dos desenhos é preciso activar as respectivas colunas:

Tanto as marcas como a cor amarela indicam que as colunas estão activas.

Agora picamos, não sobre os desenhos que queremos ver, mas sim sobre o número da respectiva
imagem (frame) na coluna cinzenta mais à esquerda.

A cor amarela indica que esta imagem está activa. Apenas são mostrados os desenhos das colunas
activas.
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Manipular desenhos dentro da Carta de Rodagem

Uma das manipulações mais frequentes dentro de uma Carta de Rodagem é  a duplicação dos desenhos
de acordo com decisões tomadas pelos animadores. O software providencia ferramentas adequadas
para esta tarefa. Por exemplo:

1 - Picar sobre o desenho 0001A (colocado na coluna “B”) e arrastar até ao desenho 0010B (colocado
mais abaixo, na coluna “A”), de modo a criar um bloco seleccionado.

2 - Segundo indicações dos animadores estes desenhos são “a dois”, ou seja, a sua duração tem que
ser duplicada. A ferramenta Repeat Cells permite fazer isso mesmo.

Mudando o valor numérico em Repeat Cells, muda simultaneamente a duração dos desenhos
seleccionados. No presente caso o valor é 2.

      

Um atalho interessante é aumentar ou diminuir a duração dos desenhos usando as teclas + e – da
almofada numérica do teclado.
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3 - Esta operação revelou um ponto fraco deste software: duplicou os desenhos, mas não duplicou os
espaços em branco na coluna “A”.

Como resultado disso os desenhos já não estão convenientemente alinhados nas duas colunas.

Neste caso concreto os 9 espaços em branco na coluna “A” também deveriam ter sido duplicados. Como
não foram, o desenho 0010B está desalinhado com o desenho 0010A em exactamente 9 unidades.

Uma maneira de solucionar isto é copiar 9 espaços vazios e inseri-los acima do desenho 0010B.
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4 - Como a coluna “C” está vazia, podemos seleccionar um bloco com 9 espaços para copiar e inserir.
Note-se que a distância entre o topo do desenho 0010B e o topo do desenho 0010A é de precisamente 9
espaços. Poderíamos também seleccionar os 9 espaços em branco imediatamente acima do desenho
0010B.

Quando se pica e arrasta a selecção, o bloco move-se como um rectângulo. Está em modo “substituir” e
não em modo “inserir”. Se fôr solto sobre quaisquer imagens vai apagá-las e sobrepôr-se a elas. Não é
isso que se pretende fazer aqui e agora. Pretende-se, isso sim, fazer uma inserção que empurre para
baixo os desenhos já existentes.

Para isso basta carregar na tecla de SHIFT e o rectângulo muda de forma.

Passa a ser uma linha horizontal que indica rigorosamente onde vai ser feita a inserção e quais os
desenhos que serão empurrados para baixo.
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Depois destas manipulações os desenhos da bola e os desenhos do futebolista ficaram outra vez bem
emparelhados:

Continuando, as indicações do animador são que os desenhos 11, 12 e 13 são “a uns”, mas os
seguintes, de 14 a 36, são “a dois”. Finalmente, os desenhos de 37 a 41 são novamente “a uns”.

Ou seja, teremos que duplicar os desenhos de 14 a 36 e deixar os outros sem qualquer duplicação.

Tal como anteriormente selecciona-se um bloco que abarque os desenhos a serem duplicados. Para isso
basta picar no desenho 0014B para o deixar seleccionado, e SHIFT-picar no desenho 0036A.

Com a ferramenta Repeat Cells duplicam-se os desenhos (ou prime-se +).



 CTP Pro Guia de Treinamento

© Crater Software 1999-2012
    www.CraterSoftware.com

44

Chegados aqui, nada como visualizar o trabalho já executado. Através do menú Player > Play Forward
ou através dos botões adequados.

          

Não esquecer o Save (Ctrl+S)
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